首页 基金 经济 期货 外汇 股票 资讯 贵金属 区块链 信用卡 网贷

大智慧奔向自由指标公式

2019-06-12 15:25 来源:[db:来源]
DRAWGBKLAST(DATE900101,STRIP(RGB(65,65,65),RGB(0,0,0),0));
趋势:SMA(((CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*100),3,1);
PARTLINE(趋势,趋势50),COLORRED,LAYER0;
PARTLINE(趋势,趋势50),COLORGREEN,LAYER0;
FILLRGN(趋势,50,趋势50,RGB(155,50,50));
FILLRGN(趋势,50,50趋势,RGB(0,100,50));
判断:SMA(趋势,3,1),COLORYELLOW;
PARTLINE(判断,判断50 AND 趋势判断 ),COLORYELLOW,LINETHICK2;
PARTLINE(判断,判断50 AND 趋势判断),COLORff00ff;
PARTLINE(判断,判断50 AND 趋势判断),COLORGREEN,LINETHICK2;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
cci:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
macd:=2*(DIFF-DEA);
转点:=IF(KD AND CCI0 AND DIFFDEA AND MACD0,1,0);
STICKLINE(转点=1,50,50,6,0),COLORYELLOW;
STICKLINE(转点=0,50,50,6,0),COLORCYAN;
顶部:90,DOTLINE,COLORYELLOW;
底部:10,DOTLINE,COLORCYAN;
DRAWICON(CROSS(趋势,判断),判断,7);
DRAWICON(CROSS(趋势,顶部),HIGH*6,8);
LC:= REF(CLOSE,1);
{MY指标公式网http://www.myzhibiao.com/}
rsi:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VAR1:=(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9))*100-70;
VAR2:=SMA(VAR1,9,1)+100;
VAR3:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR4:=SMA(VAR3,3,1);
VAR5:=SMA(VAR4,3,1)+100;
VAR6:=VAR5-VAR2;
VAR2Q:=REF(LOW,1);
VAR3Q:=SMA(ABS(LOW-VAR2Q),3,1)/SMA(MAX(LOW-VAR2Q,0),3,1)*100;
VAR4Q:=EMA(IF(CLOSE*1.3,VAR3Q*10,VAR3Q/10),3);
VAR5Q:=LLV(LOW,30);
VAR6Q:=HHV(VAR4Q,30);
VAR7Q:=IF(MA(CLOSE,58),1,0);
VAR8Q:=EMA(IF(LOW=VAR5Q,(VAR4Q+VAR6Q*2)/2,0),3)/999*VAR7Q;
逃顶:=CROSS(82,RSI);
STICKLINE( 逃顶,逃顶,20,5,0),COLORFF5500;
STICKLINE( 逃顶,逃顶,30,3,0),COLORFF8800;
STICKLINE( 逃顶,逃顶,30,2,0),COLORFFAA00;
STICKLINE( 逃顶,逃顶,30,1,0),COLORFFCC00;
D1:=(C+L+H)/3;
D2:=EMA(D1,6);
D3:=EMA(D2,5);
BBUY:=CROSS(D2,D3);
风险区:80,COLORFF85FF;
安全区:20,COLORYELLOW,POINTDOT;
天线:100,COLORFFFF00,POINTDOT,LINETHICK2;
强弱线:50,COLORGREEN,POINTDOT;
DRAWICON(BBUY,(LOW *1),7);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,15);
DRAWTEXT(CROSS(82,VARR1),35,'逃'),COLORYELLOW;

责任编辑:大智慧奔向自由指标公式

点击排行