首页 基金 经济 期货 外汇 股票 资讯 贵金属 区块链 信用卡 网贷

大智慧趋势强度指标公式

2019-06-12 15:25 来源:[db:来源]
INPUT:N1(5,2,100),N2(26,2,100),N3(45,2,100),N4(7,2,100),换手率(5,1,20);
gIFF := EMA(CLOSE,5) - EMA(CLOSE,26);
gEA := EMA(gIFF,4);
DIF1:=EMA(CLOSE,N1)-EMA(CLOSE,N2);
DEA1:=EMA(DIF1,N3);
macd:=2*(DIF1-DEA1);
MACdma:=MA(MACD,N1);
持股:STICKLINE(MACDMACDMA AND MACD0,MACD,MACDMA,8,0),COLOR9800FF;
零下 :0,COLORGREEN;
压力:MA(REF(HHV(MACD,63),1),2),COLORWHITE,LINETHICK1;
短压:MA(REF(HHV(MACD,1),1),1),COLORRED;
多:=EMA(C*5,7) - EMA(C*5,13);
空:=EMA(多,2);
Vd:=CROSS(空,多);
DRAWTEXT(Vd,短压,'跌'),coloryellow;
上趋势:=MA(LOW,20)*1.2;
次上趋势:=MA(LOW,20)*1.1;
次下趋势:=MA(HIGH,20)*0.9;
下趋势:=MA(HIGH,20)*0.8;
ZD:=(C-REF(C,1))/REF(C,1)*100;
HDZF:=(HHV(H,20)-C)/(HHV(H,20)-LLV(L,20));
{MY指标公式网http://www.myzhibiao.com/}
趋势强度:=IF(C次上趋势,IF(C上趋势,4,3),IF(C次下趋势 AND C次上趋势,2,IF(C下趋势,0,1)));
STICKLINE(趋势强度=0 ,MACD,MACDMA,6,1),COLORBLUE;
STICKLINE(趋势强度=1,MACD,MACDMA,6,1),COLORBLUE;
STICKLINE(趋势强度=2 AND 0MACD,MACD,MACDMA,7,0),COLORGRAY;
STICKLINE(趋势强度=3 AND 多空 ,MACD,MACDMA,5,0),COLORYELLOW;
STICKLINE(趋势强度=0 ,MACD,MACDMA,6,0),COLORBLUE;
STICKLINE(趋势强度=2 and 多空,MACD,MACDMA,6,0),COLORBLUE;
STICKLINE(趋势强度=4 AND 多空,MACD,MACDMA,6,0),colorred;
VdF:=SMA(1a0001$vol,10,1)/10000000;
Vd1A:=EMA(VdF,13.5);
大盘走势:(((VdF - Vd1A) / Vd1A) * 100),COLORYELLOW,linethick0;
DRAWTEXTREL(700,25,'大盘走势:'+NUMTOSTRN(大盘走势,0)),LINETHICK5,ColorFFFFFF;
极品绝底:=C-O=0 AND O/L1.05 AND L=LLV(L,30);
DRAWTEXT(极品绝底,短压,'绝底');
下:=cross(压力,短压);
DRAWTEXT(下,压力,'清仓'),Color40FF00,linethick1;
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
涨:=EMA(QW6,10)+100/2-5;
跌:=EMA(涨,4);
多线:=IF(CROSS(涨,跌) AND 跌-10,30,0);
DRAWTEXT(多线0,短压,'看涨'),COLORYELLOW;

责任编辑:大智慧趋势强度指标公式

点击排行